Según he estado leyendo después de crear una nueva aplicación web en Ruby on Rails con el comando rails new app lo que sigue es ejecutar bundle install (se ejecuta automáticamente), yo edite el Gemfile y coloqué al inicio source ‘http://nexus.prod.uci.cu/repository/rubygems-all’ reemplazando la url de internet, durante el proceso de ejecución del comando bundle install me da los siguientes errores:

Fetching gem metadata from http://nexus.prod.uci.cu/repository/rubygems-all/.
Retrying dependency api due to error (2/4): Bundler::HTTPError Network error while fetching http://nexus.prod.uci.cu/repository/rubygems-all/api/v1/dependencies?gems=rails%2Csqlite3%2Cpuma%2Csass-rails%2Cuglifier%2Ccoffee-rails%2Cjquery-rails%2Cturbolinks%2Cjbuilder%2Cbyebug%2Cweb-console%2Clisten%2Cspring%2Cspring-watcher-listen%2Ctzinfo-data…
Retrying dependency api due to error (2/4): Bundler::HTTPError Network error while fetching http://nexus.prod.uci.cu/repository/rubygems-all/api/v1/dependencies?gems=atomic%2Choe%2CZenTest%2CRubyInline%2Cfunctional-ruby%2Cruby_parser%2Cmultimap%2Cabstract%2Cloofah%2Cmime-types%2Ctreetop%2Ctlsmail%2Ctext-hyphen%2Cwebsocket-extensions%2Crspec%2Chiredis%2Ceventmachine%2Cbcrypt%2Clittle-plugger%2Cloquacious%2Cbones-git%2Cbones-extras%2Cflexmock%2Cmocha%2Cmarkaby%2Cmetaid%2Cmab%2Cdaemons%2Cgem_plugin%2Ccgi_multipart_eof_fix%2Cfastthread%2Cruby-yadis%2Ceventmachine-le%2Chttp_parser.rb%2Cpreforker%2Cracc%2Crexical%2Crake-compiler%2Cmini_portile2%2Cmini_portile%2Ctenderlove-frex%2Cweakling%2Cpkg-config%2Carchive-tar-minitar%2Chitimes%2Ccoveralls%2Crubocop%2Ccelluloid-gems%2Cdotenv-deployment%2Cwin32-security
Retrying dependency api due to error (3/4): Bundler::HTTPError Network error while fetching http://nexus.prod.uci.cu/repository/rubygems-all/api/v1/dependencies?gems=atomic%2Choe%2CZenTest%2CRubyInline%2Cfunctional-ruby%2Cruby_parser%2Cmultimap%2Cabstract%2Cloofah%2Cmime-types%2Ctreetop%2Ctlsmail%2Ctext-hyphen%2Cwebsocket-extensions%2Crspec%2Chiredis%2Ceventmachine%2Cbcrypt%2Clittle-plugger%2Cloquacious%2Cbones-git%2Cbones-extras%2Cflexmock%2Cmocha%2Cmarkaby%2Cmetaid%2Cmab%2Cdaemons%2Cgem_plugin%2Ccgi_multipart_eof_fix%2Cfastthread%2Cruby-yadis%2Ceventmachine-le%2Chttp_parser.rb%2Cpreforker%2Cracc%2Crexical%2Crake-compiler%2Cmini_portile2%2Cmini_portile%2Ctenderlove-frex%2Cweakling%2Cpkg-config%2Carchive-tar-minitar%2Chitimes%2Ccoveralls%2Crubocop%2Ccelluloid-gems%2Cdotenv-deployment%2Cwin32-security
Retrying dependency api due to error (4/4): Bundler::HTTPError Network error while fetching http://nexus.prod.uci.cu/repository/rubygems-all/api/v1/dependencies?gems=atomic%2Choe%2CZenTest%2CRubyInline%2Cfunctional-ruby%2Cruby_parser%2Cmultimap%2Cabstract%2Cloofah%2Cmime-types%2Ctreetop%2Ctlsmail%2Ctext-hyphen%2Cwebsocket-extensions%2Crspec%2Chiredis%2Ceventmachine%2Cbcrypt%2Clittle-plugger%2Cloquacious%2Cbones-git%2Cbones-extras%2Cflexmock%2Cmocha%2Cmarkaby%2Cmetaid%2Cmab%2Cdaemons%2Cgem_plugin%2Ccgi_multipart_eof_fix%2Cfastthread%2Cruby-yadis%2Ceventmachine-le%2Chttp_parser.rb%2Cpreforker%2Cracc%2Crexical%2Crake-compiler%2Cmini_portile2%2Cmini_portile%2Ctenderlove-frex%2Cweakling%2Cpkg-config%2Carchive-tar-minitar%2Chitimes%2Ccoveralls%2Crubocop%2Ccelluloid-gems%2Cdotenv-deployment%2Cwin32-security

Resolving dependencies…
Network error while fetching http://nexus.prod.uci.cu/repository/rubygems-all/quick/Marshal.4.8/puma-3.6.2.gemspec.rz

Alguien que tenga experiencia en el tema y me oriente, es que no puedo usar el servidor de dependencias de la producción??? (obviamente estoy dentro de la UCI)

Saludos!