En el pasado verano la comunidad de internacional de PostgreSQL, eliminó el soporte a la versión de la rama 8.4, como parte de su política de soporte de 5 años, la última versión que se le dio soporte fue a la 8.4.22. La próxima en eliminar el soporte será la 9.0, la cual va por la rama versión 9.0.18 y la fecha de la pérdida del soporte de la misma es en septiembre de 2015, así que aún tienen tiempo para seguir operando con esa versión del gestor.

postgresql-logo

Se recomienda que utilicen las versiones más recientes pues siempre tienen mejores prestaciones de rapidez, seguridad y estabilidad, actualmente está en la versión 9.3.5, perteneciente a la rama del 9.3 la cual tiene entre otra ventajas:

  • Agregar vistas materializadas
  • Mejoras para el tipo de dato JSON
  • Triggers sobre eventos
  • Vistas auto-actualizables
  • Mejoras en los FDW

La rama 9.4 está por salir y se espera que salga a finales de año 2014 o principio de 2015, la cual va a traer algunas mejoras, tales como:

  • Mejoras en la replicación nativa
  • Mejorar en las vistas materializadas y auto-actualizables
  • Tipos de datos JSONB (JSON binario)
  • Filtros a la funciones de agregado
  • Mejoras en la salida del EXPLAIN ANALYZE

Así que si utilizas PostgreSQL como gestor de base de datos o piensas utilizarlo comienza por una versión más reciente, así se podrá aprovechar mejor el gestor.

Fuente: PostgreSQL UCI