Uno de los primeros problemas que encontré al comenzar a utilizar OpenSuse fue que no solo cambió la extensión de la paquetería del repositorio, sino que también varias de las librerías que utilizo para desarrollar tienen un nombre diferente al utilizado en otras distribuciones como Ubuntu o Nova.

De hecho, todos los paquetes de desarrollo en lugar de utilizar en su nombre la estructura nombre-versión-dev como ocurre en Debian y derivados toman la forma nombre-versión-devel .

Justamente el hecho planteado anteriormente hizo que tuvieras problemas al tratar de instalar el IDE de Java NetBeans desde su instalador .sh ya que me decía que era imposible localizar un instalación de java OpenJDK en el sistema.

índice
Para que no les ocurra la mismo o si ya se encontraron con esta situación y aun no logran darle solución les comento que deben instalar el paquete java-1_7_0-openjdk-devel o java-1_8_0-openjdk-devel en dependencia de la versión del SDK que prefieran usar.
Para ello pueden hacerlo desde el centro de software del YaSTde manera visual.

instantánea20

O desde la consola utilizando el comando:

sudo zypper install java-1_8_0-openjdk-devel

o si prefieren el OpenJDK 7

sudo zypper install java-1_7_0-openjdk-devel

Y esto es todo, espero que le haya resultado de utilidad el tuto y si tienen algo que compartir no olviden dejárnoslo saber en los comentarios. 🙂